Rune Central

Crash bug
Page 1 of 1

Author:  Mandel [ Wed Jun 15, 2005 6:20 am ]
Post subject:  Crash bug


I've stumbled upon a bug with joequake that makes it crash systematically. And because Joequake fiddles with the gamma setting on the graphics card, I have to reboot windows in order to restore the gamma after such a crash.

The problem is in the demo menu. If I browse to a directory that has only directories in it and no demos, and type a letter with the keyboard, joequake crashes, sometimes. I don't know which letters causes the crash, it seems to be rather random. Because I have most demos in a directory called demos I want to type "de" and enter to quickly enter the directory. If I accidentally enter "sw" instead because of wrong finger alignment, joequake crashes after the letter s.

Don't get me wrong, it seems all I do is post bug reports here. The reason is that I use JoeQuake so much that I stumble upon them. I can't help it! :D

Author:  aguirRe [ Wed Jun 15, 2005 12:59 pm ]
Post subject: 

It won't cure the crash, but you can at least easily reset h/w gamma with the setgamma utility here: (scroll to bottom of page).

Author:  Jozsef [ Wed Jun 15, 2005 4:11 pm ]
Post subject: 

thanks for the report Mandel.
I'll look after the problem.

Author:  Mandel [ Thu Jun 16, 2005 3:56 am ]
Post subject: 

Thanks, to both of you!

Author:  Jozsef [ Mon Jun 20, 2005 3:59 pm ]
Post subject: 

Cant you tell any other detail with this? i try to freeze it out as you said but just cant :)
I'd like to track this problem down.

Author:  Mandel [ Tue Jun 21, 2005 4:33 am ]
Post subject: 

Sorry but at the moment that is basically all I know. I'm gonna try and get a report with drwatson or some debugger. I tried yesterday but couldn't, but I'm gonna try again.

Something very weird happened though. Once or twice, instead of crashing, it printed some random letters at the top of the file list. Like, two lines of garbage followed by the list of directories. I forgot to take a screenshot though... I seem to remember that the garbage ended up between the horizontal line and the list of files.I know this doesn't help you much but it's an interesting effect :)

Gonna try and get you some more info on this using some tips I got from aguirRe.

Author:  Mandel [ Wed Jun 22, 2005 7:05 am ]
Post subject: 

I haven't yet been able to get a good report from drWatson, sorry. But I have some interesting observations to share:

First, I don't think that it's of any use to anybody, but the error comes from address 0x00481f93 in the program, :0xc0000005. Access violation reading 0x010b0108

The same thing happens no matter what the s key is bound to. And it seems to only be the s key.

The winquake version didn't crash instantly, I think. Instead it printed garbage (SSSbbbcehlnnnooonnmlonllmnno) AND listed a few demos that lie in a directory I wasn't browsing at the time. :?: At that time I checked my disk, but it turned out to be fine.

And here's another observation, perhaps the most interesting one. The crash only occurs if I type s when I have browsed to the quake root, and if there are 12 or more subdirectories in it. I removed some directories, pressed s, and it didn't crash. I created a 12th directory, pressed s, and it did crash.

I'm perfectly willing to accept that the problem is something on my end. Looking forward to the next version of JoeQuake to see if it behaves in the same way!

Author:  aguirRe [ Wed Jun 22, 2005 1:20 pm ]
Post subject: 

That address (0x00481f93) is inside the JoeQuake exe so it's easy to find where it crashes. To find out why can be more difficult, especially without a stacktrace. But it's a good start.

Author:  Mandel [ Thu Jun 23, 2005 5:35 am ]
Post subject: 

I'll try and compile an exe myself with debug data and see if that helps.

Author:  Baker [ Thu Jun 23, 2005 7:23 pm ]
Post subject: 

Mandel, this is just me taking a stab at this mystery, no one seems to be able to recreate and this might not even be relevant.

I tried to recreate your error following exactly what you did and I didn't get it.

1. Are you using the current fmod.dll for JoeQuake? Check file date and size.

2. Are you using Windows?

3. Are you using 0.14 DEV JoeQuake from December 2004?

I seem to remember having your exact problem way back in 2003. But I haven't had the problem in ages, so it must have been fixed in one of the subsequent releases.

Page 1 of 1 All times are UTC - 5 hours [ DST ]
Powered by phpBB® Forum Software © phpBB Group